Back to overview
Downtime
Platform unavailable in Canada
Jun 10 at 04:19pm BST
Affected services
Florence Canada App and Services
Resolved
Jun 10 at 07:58pm BST
The issue with our downstream provider has resolved and we're now monitoring the situation. The platform is now fully operational
Affected services
Created
Jun 10 at 04:19pm BST
We're experiencing an outage related to a downstream issue with our hosting provider. We're doing everything we can to get the platform back online as soon as possible.
Affected services